You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
frainzy1477 fd17bc98fb
Merge pull request #338 from frainzy1477/test
1 month ago
.github/workflows Merge branch 'master' into test 2 months ago
luasrc 1.7.5.7 1 month ago
po/zh-cn 1.7.5.7 1 month ago
root 1.7.5.7 1 month ago
tools/po2lmo Makefile refine 9 months ago
LICENSE Initial commit 1 year ago
Makefile 1.7.5.7 1 month ago
README.md Update README.md 1 month ago

README.md

Clash
Luci App For Clash

A rule based custom proxy client for Openwrt based on Clash.

Install

  • Upload ipk file to tmp folder
  • cd /tmp
  • opkg update
  • opkg install luci-app-clash_v1.7.5.7_all.ipk
  • opkg install luci-app-clash_v1.7.5.7_all.ipk --force-depends

Uninstall

  • opkg remove luci-app-clash
  • opkg remove luci-app-clash --force-remove

Features

  • Subscription Config
  • Config Upload
  • Create Config
  • GeoIP Database Update
  • TProxy UDP
  • IP Query
  • DNS Forwarding
  • Support Trojan(Trojan-GFW & Trojan-Go)
  • Support SSR
  • Support SS
  • Support V2ray
  • Support Snell
  • Ping Custom Proxy Servers
  • Tun Support
  • Access Control
  • Support Provider,
  • Game Rules
  • Restore Config

Dependency

  • bash
  • coreutils
  • coreutils-nohup
  • coreutils-base64
  • ipset
  • iptables
  • luci
  • luci-base
  • wget
  • libustream-openssl
  • curl
  • jsonfilter
  • ca-certificates
  • iptables-mod-tproxy
  • kmod-tun

compile


  • Download SDK, and it’s depends:

    sudo apt-get install gawk libncurses5-dev libz-dev zlib1g-dev  git ccache
    
  • Download your own SDK

    # Untar ar71xx platform
    tar xjf OpenWrt-SDK-15.05-ar71xx-generic_gcc-4.8-linaro_uClibc-0.9.33.2.Linux-x86_64.tar.bz2
    cd OpenWrt-SDK-*
    # update feeds
    ./scripts/feeds update packages
    # Clone
    git clone https://github.com/frainzy1477/luci-app-clash.git package/luci-app-clash
    # select this package
    make menuconfig
       
    # Compile and install po2lmo bin for build i18n language files
    pushd package/luci-app-clash/tools/po2lmo
    make && sudo make install
    popd
    # I18n language files
    po2lmo ./package/luci-app-clash/po/zh-cn/clash.po ./package/luci-app-clash/po/zh-cn/clash.zh-cn.lmo
       
    # Compile
     make package/luci-app-clash/compile V=99
    

License

Luci App For Clash - OpenWrt is released under the GPL v3.0 License - see detailed LICENSE .